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FileMakerPro6

Description

This will help us on our way to learning about database

Contents

Create a New Database . . . . . . . ... . ... .. ... .. ... .. 3
Add a PicturetoalLayout . . . ... ... ... .. ... ... ... . ... 7
Define a Value List . . . . . . . .. 11
Format TextinaField . . .. . .. .. .. .. ... .. ... .. .. 14
PerformaFind . . .. .. . .. ... 20
Share a Database . . . . .. .. ... ... ... 21
Define a Number Field . . .. .. ... ... ... .. ... ... . 22
Definea TextField . . ... ... ... .. .. .. .. .. .. .. .. ... 24
Delete a Record . . . . . . .. . . ... 25
Print . . . 25

Recipes4Success www.recipes4success.com ©2008 Tech4Learning, Inc.



FileMakerPro6 Page 3 of 28

Create a New Database
FileMaker Pro 6

To open FileMaker Pro, click the Start button.
Go to All Programs, choose FileMaker Pro 5, and select FileMaker Pro.

FileMaker Pro will open and ask you if you want to create a new file or open an existing
file.

New Database

FileMaker

Pro b

(" Create a new file uzing a template:;

Y
f_%I:reate a new emphy file...
(" Open an existing file...
| Mo longer show thiz dialog j
Template Info... ak. Cancel |

Click the Create a new empty file radio button.

Click the OK button.
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Create New File

Save in; |E:'| My Documents j ﬁi -
My Music

E}My‘ Pictures

EMY Yideos

Filz nama: |States| Save
Save as type: |Fi|efv'|a|-:er Files (" fp5;* fp3;" fm) ﬂ Cancel

Locate a place to save the file.
In the File name field, type a name for the new database.
Click the Save button.

The new database will be created and a dialog will open asking you to define the fields
for the database.
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Define Fields for "States.fp5”

0 figld(z]

View by | creation order

Field Mame

Optiohs

Field Mame |Namﬂ
Type
(o Teut
" Mumber

[~ Date
7 Time

Type the name of the first field in the Field Name field.

Click the Create button.

(" Container
(" Calculation

{7 Summary
(" Global

Create
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Define Fields for "States.fp2”

B field(=) Wiew by | custorn order

Field Mame O phions
Marne

Capital
Fopulation
Largest City
State Flower
b ajor [nduztog

Field Hame  |[SE R RELN
Type
o Teut " Container
C Number {" Calculation

(" Date C" Summary
" Time (" Glaobal Delete Done

Create Ophions...

Duplicate

Repeat this process for each of the fields you want to create.

When you are finished, click the Done button.
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&Y FileMaker Pro

File Edit View Insert Format Records Scripts Window Help
D@ &Y BE S S & & O

[ States.fp5

Layout #1

Records:
1

Urzarted

100] ool 5| Browese

For Help, press F1
You can now begin entering data into the new database.

Add a Picture to a Layout
FileMaker Pro 6

Go to the View menu and choose Layout Mode.
Go to the Insert menu and choose Picture.

At the Insert Picture dialog, navigate to the location of the picture.
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Insert Picture

Look in: |B Sample Pictures ﬂ = =5 EE-

Blue hills.jpg
E‘J_] Sunset.jpg
E‘J] Water lilies.jpg

E‘J] Winter.jpg

File name:  [Blue hils jpg

Files of type: |.ﬂ]I Files 7.7

| Stare only a reference ta the file

[~

Open

Cancel

Click the file you want to use.
Click the Open button.

The picture will appear in the layout.
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#¥ FileMaker Pro
File Edit WView Insert Format Layouts Arrange Scripts Window Help

DS g¥ sa@a o
[ States.fp5

Layout #1 ~r| Header |

atate Mame
1

K| % |
& @

A i e

I & op

1DD|.J!E = Lavout -/

For Help, press F1 | NUM | y

To move the picture, click and drag the picture to a new location in the layout.
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#¥ FileMaker Pro

File Edit View

O = % E;’ .;lﬂln !

% States.fp5

Layout #1 ~r|

|

Layouts:
1

Evl?ﬁﬁle-l
0 & opt

Header |

Insert Format Layouts Arrange Scripts  Window Help

Body |

atate Mame

apital

Fopulation

Largest City

atate Flower

ajnrindus

Foater
1DD|..|H|E|EI| Layout -4 | 2 |

For Help, press F1

MLIM

To resize the picture, click it.

A handle will appear at each corner of the picture.
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#¥ FileMaker Pro
File Edit WView Insert Format Layouts Arrange Scripts Window Help

DE &% % & @ | & e Q)
% States.fp5

Layout #1 ~r| Header ]

=tate MName
i Lapital
: Fopulation
1 Largest City

Layouts:

1 atate Flower

ajnrindus

Evl?ﬁﬁle-l
0 & opt

Body |

%

Foater -
1DD|..|H|E|EI| Layout -4 | 2 |

For Help, press F1

MLIM

Click and drag one of the handles to resize the picture.

Define a Value List
FileMaker Pro 6

Go to the File menu and choose Define Value Lists.

At the Define Value Lists dialog, click the New button.
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Define Value Lists for "us_states.fph”

Walue ligts provide predefined lists for data entry, 0 walue ligt[z)
data wvalidation and zorking.

Wigw b | creation order ﬂ

Yalue List Name Source Yalues |

At the Edit Value List dialog, type a name in the Value List Name field.
Click the Custom Value field and type the first value.

Press the Enter key on the keyboard.

Type the second value.

Press the Enter key on the keyboard.

Continue entering values.
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Edit Value List

Yalue List Mame |h-1_|,| Yalue List

(o ze custom values:

E ach walue must be separated
by a camage return.

Add a divider by entering a
bwphen """ on a line by itzelf.

(" Uze values from feld:

{7 Uge value ligt from anather file;

Wallue 1
Walue 2
Walue 3
Walue 4

Cancel

When you are finished, click the OK button.
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Define Value Lists for "us_states.fp5”

YWalue ligts provide predefined lists for data entry,

data validation and sarking.

1 walue list[z)

Wiew by | creation order j

W alue List Mame
# My ifalue List Custom List

Duplicate

"alue 1", "alue 2 alue 3" "Yalue 4"

Delete

At the Define Value Lists dialog, click the Done button.

Format Text in a Field
FileMaker Pro 6

Go to the View menu and choose Layout mode.

Click the field that you want to change.

Recipes4Success www.recipes4success.com ©2008 Tech4Learning, Inc.



FileMakerPro6 Page 15 of 28

#¥ FileMaker Pro
File Edit Yiew Insert Format Layouts Arrange Scripts  Window Help

= &V & ] &
% States.fp5

State ... = =l

Header | s
St Mame  [Slate Mame [
capasl  |Capital 5
1 Fopeiston  |Eopulation...]
1

e

Layauts: Largest City  |L.argest City

Si=t= Flowsr  [SlAte Flower
Major Indestry  (MALGCINGLSE

_|_|_|E' Zv| v Body ]

‘5:' Iéh Footer
B~ | % E-|
B4 1p
'IDD|_.||I|E|EI| Layaut
For Help, press F1 MUM

Go to the Format menu and choose Text.

At the Text Format dialog, select a font using the Font pull-down menu.
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Text Format for "State Name"

Fant:
Size:

Calar:

Sample

By Avial |

M
Anal Baltic

T Adial Black
T Anal CE

T Anal CYR
T Adal Greek
T Arial Narrow

T Asial TUR v

Automate sophisticated tasks
without programming.

Faragraph...

Style

v Flain

| Bald

| Italic

| Strikeout

| Small Caps
| Underline

[ word Underline
| Double Underline

| Superscript
[ Subscript

| Condenze
| Extend

[~ Case: | UPPERCASE - |

OF.

Cancel |

Select a font size using the Size pull-down menu.
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Text Format for "State Name"

Style

Font; |f&' il j % Plan
Size: | 12 | [ Bold [ Superscript
Colar: ::i ~ | Italic | Subszcript
18 | Shikeout | Condenze
Samphw | SmallCaps | Extend
ig | Underline
Automn| 72 | Word Underline

withou —— - b’ | Double Underline
[~ Case: | UPPERCASE - |

Faragraph... ()4 Cancel |

You will see a sample of your text format in the Sample area.

Click the Color pull-down menu to view a color palette. Click a color.
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Text Format for "State Name"

Style
Font: |f&' Arial j % Plain
Size: | 24 j | Boald | Superscript
Calar; : | Italic | Subscript
EEEPEEEEEE Stikeout | Condenze
cample |l EEPEEEENEERE Small Capz | Extend
U | Uncetine
ALH BE R B BB B | word Underline
SO B [0 P B Double Underline
F 1 ] B0 | Case: | UPPERCASE |
B |
Faragra ] ()4 Cancel |
Other Color...

In the Style area, click a check box to select a style for your text.

When you are finished, click the OK button.
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#¥ FileMaker Pro
File Edit Yiew Insert Format Layouts Arrange Scripts Window Help

D= &V | &
[ States.fp5

Layot 1¢1v| Header ]

Population
L.argest City
Slate Flower
Kajor industry

8| 7| %-|| Body |
& Footer ]
100] ool 5 =] Lyt~ 4] |

For Help, press F1

You may need to rearrange the fields so that your new text style fits in the layout. To
move a field, click and drag the field to a new location.
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#¥ FileMaker Pro
File Edit Yiew Insert Format Layouts Arrange Scripts Window Help

e &V
[ States.fp5

Layot 1¢1v| Header ]

Name

apifal
Fopulation
Largest City
lale Elower
Waiarindustny

M| % || Body |

@;' B Footer |
100] ool 59 =9 Lyt~ 4] |

For Help, press F1

Perform a Find
FileMaker Pro 6

Go to the View menu and choose Find Mode.
Click the field you want to use.

Type the information that you are looking for.
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#¥ FileMaker Pro
File Edit %Yiew Insert Format Reguests Scripts Window Help

[ = &
[ States.fp5

Layout #1 =

Name |TExas
Capital |
Populstion

Requests:
1

[ Omit
Symbols ﬂ

100] o) ol 5

For Help, press F1

Press the Find button on the left side of the screen.

FileMaker Pro will display the records that match your search criteria.

Share a Database
FileMaker Pro 6

Go to the File menu and choose Sharing.

At the File Sharing dialog, click the Multi-User radio button.
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File Sharing for "States.fpb”

Filetd aker Metwork, Sharing

Thiz file will be shared Uking 'TCFAF'.

Companion Sharing

Shared Companion Mame

[ Single User (4. Mulbi-Uzer {7 Muli-Uszer [Hidden)

] Local Data Access Companion
O
O

[
[

Ok,

Cancel |

Click the OK button.

To access a shared database from another computer, you must put the database in a
location that is accessible from multiple computers, such as on a networked file server.

The first person to open the shared database will be the host for all users. The host

must also be the last person to close the database.

Define a Number Field
FileMaker Pro 6

Go to the File menu and choose Define Fields.
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At the Define Fields dialog, type the name of the number field in the Field Name field.

In the Type area, click the Number radio button.

Define Fields for "States.fp”

2 field[z] View by | creation order

Field M arme Optionz
# State Mame
# LCapital

Field MNamne |F'|:||:|ulati|:|n

Type

{7 Test (" Container
f"]; Murnber [ Calculation

ate {7 Summary
£ Time (" Global

Click the Create button.

Click the Done button.
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Define a Text Field
FileMaker Pro 6

Go to the File menu and choose Define Fields.
At the Define Fields dialog, type the name of the text field in the Field Name field.

In the Type area, click the Text radio button. This will allow you to enter any type of text
in this field.

Define Fields for "States.fp”

1 field[z] View by | creation order

Field M arme Optionz
# State Mame

Field MNamne |Ea|:uital
Type

Create

(s Text (" Container

r%Numl:uar {7 Calculation
(" Date {7 Summary

" Time (" Global
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Click the Create button.
Repeat this process to create additional fields.

When you are finished, click the Done button.

Delete a Record
FileMaker Pro 6

Locate the record that you want to delete.

Go to the Toolbar and click the Delete Record button.

DS &% Elﬁ & 0

Delete Record

At the dialog, click the Delete button.

FileMaker Pro

!

'|_q, FPermanently delete thiz EMTIRE record?

Delete |

x

Cancel

This will remove the current record from the database.

Print
FileMaker Pro 6

Go to the Toolbar and click the Print button.
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=¥ FileMaker Pro
File Edit View Insert Format Records Scripts Window Help

D & %“& ClE IR e

Print

The Print dialog will appear.

To print all of the records in the database, use the Print pull-down menu and choose
Records being browsed.
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Print

Frirt: |F|ec:n:|n:|3 being browvwsed j
Records being browsed

PrinlCurrent recaord

St TTEEY
Type: HF Lazerlet 4050 Senes PCL &
Where:  HPLazerletd0505enes

Camment:

(" Pages from: |1 bo; |E|E|E|E|

Mumber pages from: | 1

OLE
| Update all Links befare printing

Blank record, showing fields
MafField definitions d

i3

Froperties...

Frint range Copies

(o Al Mumber of copies: | El

| Print ta file

-

k.

Cancel

To print only the record you are viewing, use the Print pull-down menu and choose

Current record.
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Print

Frirt: |F|ec:n:|n:|3 being browvwsed j
Record: being browsed

Blank record, sho field=

ManField definitions

- | Froperties...

St TTEEY
Type: HF Lazerlet 4050 Senes PCL &
Where:  HPLazerletd0505enes

Comment: | Print ta file

Frint range Copies

v Al MNumber of copies: | El
(" Pages from: |1 bo; |E|E|E|E|

=
Mumber pages from: | 1
OLE
| Update all Links befare printing ak
Canicel

Click the OK button.
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